Как склеить два Excel-файла по общему столбцу?

Есть специальная формула ВПР, пишем ее в тот столбец который нужно заполнить,
выбираем что сравнивать, и откуда брать данные и все заполняется :)

подробнее

Примерный вид формулы:
=ВПР(A1;[диапазон значений в док-те, где паспорт]A:B;2;0)
функции-ВПР-искомое значение (фамилия на 1 листе)-табл. массивов (выбираете др документ, предварительно откройте его, в нём оба столбика (с фамилией и №№ паспорта))-№ индекса столбца (ставите 2) — диапазон просмотра (ставите 0)-enter? растягивайте формулу до конца столбца